Aspera Connect: Not working with Firefox & Edge

Note: Ci has updated the integration and support for Aspera Connect.  All users should update to the current version of Aspera Connect for their OS and install the extensions/add-ons across the users choice of web browsers.

As of Monday, December 9th, 2019, IBM Aspera revoked a certificate used for local.connectme.us that rendered previous versions of Aspera Connect below version 3.9 not usable.  Please this reference from the IBM Aspera site:

https://www.ibm.com/support/pages/security-bulletin-denial-service-vulnerability-affecting-aspera-connect-37-or-38

This is currently affecting users who are using Firefox and Edge web browsers with Aspera Connect and Ci.  The experience will behave as if Ci, when attempting to upload or download with Aspera Connect, is not finding the installation of Aspera Connect and takes the user into a loop of trying to upgrade.  In fact, even upgrading to the latest version of Aspera will not remedy that situation for Firefox and Edge.  Both the Aspera Connect client version for the user and the Ci web application need to be running on version 3.9, specifically the 3.9 SDK at the application level, and leverage some additional configurations with Aspera to allow for the Firefox and Edge web browsers to work again with Aspera Connect as well as other browsers to switch to an updated installation approach.

We recommend that while the Ci team is working on changes in order to react to Aspera's certificate revocation please use Chrome, Internet Explorer or Safari when attempting to use Aspera Connect for uploading or downloading content.

The Ci Team is diligently working on a resolution and will update users when a new approach is available to broaden the support for Aspera Connect with Ci to Firefox and Edge web browsers.

For any additional questions, please reach out to the Ci Customer Success Team by submitting a request here in the Help Center.

 

Have more questions? Submit a request